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The Windows based set-up program is menu driven, allowing the user 
to easily view data, alter set-up variables or set machine timing 
(resolver offset, timing signal locations, etc.), using a PC running the 
Windows (95/98/ME/2000/XP/NT) operating system. The set-up 
variables are used to configure and tune the M4500 to match the 
configuration and performance of the specific bodymaker (see HSL-
WI3 Set-up, section 2.8). 
 
Note:  The set-up program is an on-line communications program 
used to interface with the M4500 module.  The data displayed and set 
in the windows is communicated directly to the module, while in the 
“Online” edit mode. Therefore, prior to going online with the 
processor, make sure an RS-232 cable is connected from the COM 
port on the computer to the "PROG" port on the M4500.  The 
variables displayed while in the “Online” edit mode are read directly 
from the processor.  Data is saved to a “Set-up Data” file (*.sdt) 
whenever changes are made to a parameter or if the data is uploaded 
from the processor. 
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________________________________________________________ 
4.1 GENERAL DESCRIPTION 
 
Title Bar:  At the top of the window is the “Title Bar”.  The title bar 
is used to display the name of the working “Set-up Data” file, as well 
as, the name of the active “Window”.  The title bar is dark if the 
window is active and grayed if another window is active.  The color 
depends on the settings of the Display Properties of the Control Panel. 
 
Status Bar:  At the bottom of the window is the “Status Bar”.  The 
status bar is used to display system messages, online or offline mode, 
as well as, the current time and date as set by the operating system.  
The system messages panel displays general information about 
operation of the system.  The Online/Offline mode panel displays the 
status of the current set-up program mode of operation.  The mode of 
operation can be changed by simply double clicking the online/offline 
mode panel. 
 
Hot Keys:  Hot keys are activated by holding down the “ALT” key 
and simultaneously pressing the underlined letter of the desired 
function.  Almost every function can be activated by either pressing a 
series of hot keys or using the “TAB” key to move between fields. 
 
Online/Offline Modes:  The set-up program allows the user to 
make changes while “Online” with the processor.  The “Offline” 
mode is used to preset parameters prior to download.  All functions 
are available to the user while “Online”, however, specific “Online” 
functions are disabled in the “Offline” edit mode. 
 
Note:  Offline changes can only be made by enabling “Offline 
Editing”, accessed from the “Edit” menu. 
 
Getting Help:  The entire contents of the user’s manual is contained 
within the help file.  Pressing Ctrl+H will display the help file 
window.  Pressing the F1 key will display the contents file.  Hot spots 
allow jumps to other topics to display additional information as 
desired.  Selecting “About HSMWI7” from the Help menu will 
display a dialog box listing information about the current revision of 
the setup program and how to obtain technical support. 
 



SECTION 4 
HSMWI7 WINDOWS BASED 

SET-UP PROGRAM REFERENCE 

 
HSL-WI3 User’s Manual SYSTEMS Electronics Group 

 
- 41 - 

________________________________________________________ 
4.2 THE FILE MENU 
 
The “File” menu allows the user to perform the following functions: 
 
• Create a “New” set-up “Data File”. 
• Open an existing “Data File”. 
• Save any changes made to the current “Data File” to disk. 
• Upload (save) Data from the Processor. 
• Download a SYSdev (.sdv) program to the processor 
• Download (restore) Data from the current set-up “Data File” to 

the processor 
• Print a Report of the current set-up parameters. 
• Exit the set-up program 
 

 
 
 



SECTION 4 
HSMWI7 WINDOWS BASED 
SET-UP PROGRAM REFERENCE 

 
HSL-WI3 User’s Manual SYSTEMS Electronics Group 

 
- 42 - 

________________________________________________________ 
4.2.1 THE SET-UP DATA FILE 
 
The set-up “Data File” (.sdt) is a binary access file, designed for fast 
file I/O operation.  When the set-up program is first invoked, the 
default set-up parameters are loaded into memory.  If changes are 
made to any of the set-up parameters (either online or offline), as well 
as shift data, the user will be flagged to “Save Changes” upon exit of 
the program. 
 
Note:  Any windows based “Set-up” program can open a set-up 
“Data File”, however, the data tables will not be properly aligned.  
The user will be alerted to the problem if a set-up data file has been 
created by either a different set-up program or a different revision of 
the software. 
 
The set-up “Data File” is similar to that of a word processing file.  
When the program first starts, a default file is loaded and the user is 
able to make any changes as desired.  The set-up program is unaware 
of the settings and parameters that exist within the M4500.  
Therefore, to normalize the set-up program with the processor, the 
user should define or open an existing file, then upload “All” 
variables from the processor.  This allows the user to either create a 
backup of the data or maintain an existing file.  The user can even 
open a data file for another bodymaker, save the file to a new name, 
make the necessary changes and simply download the new parameters 
to another processor. 
 
The following functions can be accessed any time, from any set-up or 
display windows. 
 
New:  To create a “New” data file, select “New” from the “File” 
menu or press “Ctrl + N”.  This creates a completely new file, loaded 
with the default variables and the word “[unnamed]” is displayed in 
the title bar.  If any changes were made to the existing file, the user is 
prompted to save changes to the existing file. 
 
Open:  To “Open” and existing data file, select “Open” from the 
“File” menu or press “Ctrl + O”.  This displays a dialog box allowing 
the user to select an existing data file to open. The name of the file 
will be displayed in the title bar.  If any changes were made to the 
existing file, the user will be prompted to save any changes before 
terminating the program. 
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Save:  To “Save” data file to disk, select “Save” from the “File” 
menu or press “Ctrl + S”.  This displays a dialog box allowing the 
user to select a folder and enter a name for the file.  The user will be 
notified if the file already exists and the extension “.sdt” will 
automatically be added to the file name.  If this is a “New” file, the 
user will be prompted to enter a file name. 
 
Save As:  To save the data file to a new name, select “Save As” 
from the “File” menu..  This displays a dialog box allowing the user 
to select a folder and enter in a new name for the file.  The user will 
be notified if the file exists and the extension “.sdt” will automatically 
be added to the file name. 
 
Export Shift Data…:  This function allows the user to export the 
shift data to a “Tab Delimited” text file.  This allows the user to easily 
use the shift data to produce production reports. 
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________________________________________________________ 
4.2.2 UPLOAD (SAVE) DATA 
 
The “Set-up” program allows the user to upload set-up parameters, 
timing channel set-points and shift data from the M4500 into a set-up 
“Data File”.  This function is accessed from the “File” menu and the 
user is given the choice of the following options: 
 

 
 
Set-up Parameters:  This option uploads the “Set-up” data from 
the M4500.  This includes bodymaker and trimmer set-up parameters. 
 
Timing Channels:  This option uploads the “Machine Timing” 
channel set-points, as well as, the PLS configuration and scale factor. 
 
Shift Data:  This option uploads the “Shift Data” from the M4500.  
This includes the total good cans and total short cans for both the 
current and last shifts. 
 
All:  This option allows the user to completely upload “All” of the 
set-up parameters, timing channel set-points and shift data from the 
M4500. 
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________________________________________________________ 
4.2.3 DOWNLOAD PROGRAM 
 
The “Set-up” program allows the user to “Download” any SYSdev 
program file to the M4500. 
 

 
 
Note:  To “Download” a SYSdev program to the processor, the 
program must be “Online”.  If “Online” mode cannot be achieved, 
program download will not be executed.  If the program is currently 
“Offline”, the user will be prompted to first go “Online”. 
 
Once selected, and the set-up program “Online” with the processor, a 
dialog box will be displayed, allowing the user to select the SYSdev 
file to download. 
 
Note:  Only the files with the “.sdv” file extension will be displayed.  
It is important to keep in mind that only a valid M4500 PLC SYSdev 
file can be downloaded through the set-up program.  Care should be 
taken when selecting a program to download. 
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Once selected, a message box is displayed informing the user of the 
current program, revision and checksum of the program loaded in the 
processor, as well as, that of the selected program.  The user must 
confirm their selection by clicking the “Yes” command button.  After 
the user confirms their choice, program download is initiated and the 
current program download address is displayed.  When program 
download is complete, the user is prompted to acknowledge.  Control 
is passed back to the main program and the set-up program remains in 
an “Online” edit mode. 
 
 
________________________________________________________ 
4.2.4 DOWNLOAD (RESTORE) DATA 
 
The set-up program allows the user to download  “Set-up” 
parameters, timing channel set-points and shift data to the M4500 
from the set-up “Data File”.  This function is accessed from the “File” 
menu and the user is given the choice of the following options: 
 

 
 
Set-up Parameters:  This option downloads the “Set-up” data to 
the M4500.  This includes bodymaker and trimmer set-up parameters. 
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Timing Channels:  This option downloads the “Machine Timing” 
channel set-points, as well as the PLS configuration and scale factor 
to the M4500 PLS. 
 
Shift Data:  This option downloads the “Shift Data” to the M4500.  
This includes the total good cans and total short cans for both the 
current and last shifts. 
 
All:  This option allows the user to completely download “All” of the 
set-up parameters, timing channel set-points and shift data to the 
M4500. 
 
Note:  Only the values contained within the current data file are used.  
If the validity of the current data file is questionable, review the data 
in an “Offline” mode prior to download. 
 
 
________________________________________________________ 
4.2.5 PRINT REPORT 
 
The “Set-up” program allows the user to generate a “Report” printout 
of all the set-up parameters, timing channel set-points and shift data.  
This function is accessed from the “File” menu. 
 
At the top of each page, the report displays the name of the set-up file 
being printed.  At the bottom of each page is the date and time the 
document was printed, as well as, the page number. 
 
To printout a report of the settings contained in the set-up “Data File”, 
perform the following: 
 
1) From the “File” menu, select “Print Report” or press “Ctrl + P”.  

This displays the “Print Setup” dialog box, allowing the user to 
select a printer, as well as, the paper size and orientation.  Once 
the user selects “OK”, the report is generated and sent to the 
specified printer device.  This function makes use of the windows 
print manager, which allows the user to continue with their work 
while the document is being printed. 
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________________________________________________________ 
4.3 THE EDIT MENU 
 
The “Edit” menu allows the user to perform the following functions: 
 
• Enable/Disable Offline Editing. 
• Set-up the Comm Port. 
• Set the Set-up Passcode 
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________________________________________________________ 
4.3.1 ENABLE OFFLINE EDITING 
 
This function allows the user to perform “Offline” editing on the 
currently loaded set-up data file.  This allows the user the ability to 
make any necessary changes to the set-up parameters while not online 
with the processor.   
 
If offline editing is not enabled, the user is only able to view the set-
up parameters and shift data.  When the program is first invoked, the 
default setting is offline editing disabled.  The user will need to 
specifically select “Enable Offline Editing” from the edit menu (or 
press function key F2) to enable/disable this feature. 
 
 
________________________________________________________ 
4.3.2 SETUP COMM PORT 
 
This function allows the user to specify the serial communications 
port and baud rate to talk to the M4500.  The programming port of the 
M4500 is set to 9600 baud.   
 

 
 
Once selected, a dialog box requesting the user to select a “Comm 
Port” and “Baud Rate” will be displayed.  The default setting is 
COM1 at 9600 baud.  The option to select the 19200 baud rate is to 
allow the user to communicate with the processor via the S4516 serial 
communications board. 
 
In most cases the user will only need to specify the communications 
port and leave the baud rate at 9600.  If communication problems 
occur, make sure there is a secure connection from the PC to the PLC.  
Then check the Comm port.  In most cases the user will only need to 
select a new Comm port.  If communication problems persist, there 
may be another program causing a conflict with the port.  Check the 
port configuration from the “Settings” folder. 
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________________________________________________________ 
4.3.3 EDIT SET-UP PASSCODE 
 
The edit “Set-up Passcode” is an “Online” function only.  This allows 
the user the ability to directly change the value of the “Set-up 
Passcode”.  The passcode is not included as part of the setup data file. 
 
Once selected, an input box is displayed, allowing the user to view 
the current “Passcode” setting and to change the value if necessary.  If 
the passcode is set to zero, passcode entry is disabled.  The operator 
can press the Set-up key on the Keypad/Display and simply press the 
<ENTER> key to gain access to the set-up parameters without having 
to enter a zero.  
 
If the value of the passcode is a value between 1 and 65,000, 
“Passcode Entry” is enabled.  This requires the operator to enter in the 
“Correct” passcode to gain access to the set-up parameters. 
 
Note:  Passcode entry is only in effect when the “Set-up Enable” 
selector switch is in the “Disable” position. 
 
If an invalid value is entered, the passcode value will not be reset and 
a message box notifying the user of the error is displayed. 
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________________________________________________________ 
4.4 THE VIEW MENU 
 
The “View” menu allows the user to perform the following functions: 
 
• View the “Target Board Interface” 
• View “Online” Data 
• View “Offline” Data 
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________________________________________________________ 
4.4.1 TARGET BOARD INTERFACE 
 
This function allows the user to view fault codes, S3000 network 
communication error codes and review the current “Ident” and 
“Revision” of the application program.  This is accessed by the 
“View” menu, by selecting “Target Board Interface”. 
 

 
 
Once invoked, the set-up program will prompt the user to select a 
program to compare with the one existing in the processor.  Whether 
a program is selected or the user cancels, the setup program will 
attempt to communicate with the M4500.  If unsuccessful, a warning 
message will be displayed, prompting the user to either “Retry” or 
“Cancel” the operation.  If the operation is canceled and 
communication with the processor cannot be established the system 
will be placed in an “Offline” mode, however the “Target Board 
Interface” window will still be displayed. 
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________________________________________________________ 
4.4.2 VIEW ONLINE DATA 
 
This function allows the user to place the set-up program in an 
“Online” mode with the processor.  This is accessed by the “View” 
menu, by selecting “Online Data” or by simply pressing the “F3” 
function key. 
 
Note:  The program can be toggled between “Offline” and “Online” 
by simply double clicking on the “Online” or “Offline” panel 
displayed in the status bar at the bottom of the window. 
 
Once invoked, the set-up program will attempt to open the Comm 
port and communicate with the M4500.  If the set-up program is 
unsuccessful, a warning message will be displayed prompting the user 
to either “Retry” or “Cancel” the operation.  If the operation is 
canceled and communication with the processor cannot be established 
the system will be placed in an “Offline” edit mode. 
 
Note:  Anytime while the set-up program is “Online” with the 
processor and communication is interrupted, a warning message will 
be displayed, prompting the user to either “Retry” or “Cancel” the 
operation. 
 
 
________________________________________________________ 
4.4.3 VIEW OFFLINE DATA 
 
This function allows the user to place the set-up program in an 
“Offline” mode.  This is accessed by the “View” menu, by selecting 
“Offline Data” or by simply pressing the “F4” function key.  This 
allows the user to perform “Offline” editing.  All values displayed in 
“Offline” edit mode reflect the actual values contained in the 
currently loaded set-up data file. 
 
Note:  The program can be toggled between “Online” and “Offline” 
by simply double clicking on the “Online” or “Offline” panel 
displayed in the status bar at the bottom of the window. 
 
Once invoked, the set-up program will close the Comm port and cease 
communication with the M4500. 
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________________________________________________________ 
4.5 THE WINDOW MENU 
 
The “Window” menu allows the user to select one of 5 different 
Display/Set-up windows to modify set-up parameters, view shift data 
or receive feedback about the current status of the control system. 
 

 
 
Once a window menu item is selected, a check mark is placed next to 
the selected item and the selected window is displayed with the name 
changed in the title bar of the main window. 
 
Note:  “Read” only variables are displayed in blue with a gray 
background.  Any variables that can be altered by the user are 
displayed in black with a white background.  In most cases, a 
parameter that can be changed by the user will have associated with it 
increment and decrement controls.  The user can either click on the 
desired parameter to adjust and enter in a new value, or use the 
increment or decrement controls to change the value by 1 unit. 
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________________________________________________________ 
4.5.1 THE MAIN DISPLAY WINDOW 
 
The “Main Display” window is used to display the general state of the 
control system.  This window is selected from the “Window”. 
 

 
 
The following is a list of the functions of the “Main Display” 
window. 
 
Messages:  The “Messages” display is continuously updated.  It 
displays alarm and status messages specific to the M4500, as well as, 
the current “Online” or “Offline” status of the set-up program.  By 
simply scrolling the display, the user is able to view all active alarm 
and status messages.  If no alarm or status messages are active, a 
default message is displayed. 
 
Machine Speed:  This display is only active while “Online” and 
displays the current speed of the machine in “Strokes Per Minute”. 
 
Position:  This display is only active while “Online” and displays 
the current angular position of the Bodymaker crankshaft. 
 
Good Cans:  This display is the “Current Shift” total number of 
good cans so far into the current shift.   
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Short Cans:  This display is the “Current Shift” total number of 
short can faults that the machine has had so far into the current shift. 
 
Brake Response:  This is the brake response of both the low and 
high speed stops.  The response is the number of degrees it takes the 
press to stop from when the clutch is de-activated for a BDC stop to 
the position that the machine comes to rest. 
 
 
________________________________________________________ 
4.5.2 THE SETUP PARAMETERS WINDOW 
 
The “Set-up Parameters” window is used to view and adjust any of 
the set-up parameters.  This window is selected from the “Window” 
menu. 
 

 
 
This window utilizes a “TAB” control to divide the set-up parameters 
into three categories, similar to that of the Keypad/Display. 
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Brake Wear Compensation:  This section is used to set the brake 
wear compensation parameters in the M4500.  This section contains 
the following selections: 
 
1) Brake Wear Compensation Enable: This prompt is used to 

enable or disable the brake wear compensation. If the 
compensation is to be disabled, deselect the check box. If the 
compensation is to be enabled, select the check box. 

 
 The HSL-WI3 incorporates a brake wear compensation or 

automatic BDC timing feature, which stops the press at “Back 
Dead Center” regardless of the actual braking response of the 
clutch/brake. The stopping compensation is accomplished by 
automatically adjusting the BDC timing signal based on the 
previous stop. Any overrun is detected and a new BDC timing 
signal is computed such that the machine will stop at the desired 
location on the next stop. Two BDC signals are provided: one for 
low speed and one for high speed. Both incorporate the break 
wear compensation feature. The appropriate BDC timing signal 
(low or high) is adjusted based on the speed of the machine when 
the BDC stop was initiated. 

 
2) Desired BDC Stop Position (Low Speed): This is the 

desired stopping location (in degrees) for a BDC stop at low speed 
when the brake wear compensation is enabled. This is typical set 
to 000 degrees (Back Dead Center). 

 
3) Desired BDC Stop Position (High Speed): This is the 

desired stopping location (in degrees) for a BDC stop in high 
speed when the brake wear compensation is enabled. This is 
typical set to 000 degrees (Back Dead Center). 

 
4) Maximum Allowed Stopping Response (degrees): This 

defines what the maximum allowed brake response is before the 
"Brake Response Too Long" alarm is generated. If the actual 
brake response (number of degrees from when the brake is 
activated to the position where the press ends up at rest) when a 
BDC stop is performed is longer than this number, the alarm is 
generated. If the actual brake response is less, the alarm is not 
generated. Set this parameter to the value where the brake 
response is considered too long and service to the brake should be 
performed (typically 270 to 300 degrees). 



SECTION 4 
HSMWI7 WINDOWS BASED 
SET-UP PROGRAM REFERENCE 

 
HSL-WI3 User’s Manual SYSTEMS Electronics Group 

 
- 58 - 

Bodymaker Running Speeds:  This section is used to set the 
bodymaker running speeds in the M4500.  This section contains the 
following selections: 
 
1) Running Bodymaker Low Speed (SPM): This is the speed 

(in strokes per minute), that the bodymaker will run when in low 
speed. 

 
2) Running Bodymaker High Speed (SPM): This is the speed 

(in strokes per minute), that the bodymaker will run when in high 
speed. 

 
 
Trimmer Parameters:  This section is used to set the trimmer 
speed references in the M4500.  This section contains the following 
selections: 
 

 
 
1) Trimmer Maximum Speed (CPM): The "Trimmer Maximum 

Speed" parameter is used to scale the 0-10VDC analog output 
such that when the bodymaker is running at the speed entered in 
"Trimmer Maximum Speed", the analog output will be at 10 volts. 
This is typically set to the running high speed of the Bodymaker 
or slightly higher. 
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2) Trimmer Idle Speed (CPM): This parameter determines the 
speed the trimmer will run at when the bodymaker is stopped (de-
clutched).  

 
 Note: When the bodymaker is running, the trimmer speed 

reference is proportional (as set by the "Trimmer Maximum 
Speed" scaling) to the speed of the bodymaker. This parameter is 
used to provide the speed reference when the bodymaker speed is 
zero. 

 
3) Trimmer High Speed Offset: This parameter is used to 

modulate the speed of the trimmer as a function of cans present at 
the infeed of the trimmer. A high infeed sensor can be added to 
the trimmer infeed such that the trimmer will run at the 
bodymaker running speed plus the "Trimmer High Speed Offset" 
value. This allows the trimmer to speed up when the infeed to the 
trimmer backs-up and slow down once the trimmer runs the cans 
out. 
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________________________________________________________ 
4.5.3 THE MACHINE TIMING WINDOW 
 
The Machine Timing window is used to invoke the PLS programming 
command menus.  From this window, the user can view or adjust the 
following parameters: 
 
• Adjust Timing Channel setpoints. 
• Set the Main Crank resolver offset. 
• Clear or Recall a PLS timing channel. 
• View the current PLS configuration 
• Reset the PLS configuration to default settings. 
 

 
 
In addition, the following parameters are displayed at the bottom of 
this window: 
 
RPM:  This is the current speed in “Revolutions per Minute” of the 
main crank resolver. 
 
Position:  This is the current “Position” in degrees of the main crank 
resolver. 
 
Offset:  This is the current resolver offset (set in degrees). 
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Scale:  This is the scale factor of the resolver or the number of 
divisions in one revolution. 
 
Note:  The General Timing Signal Locations section provides a 
complete description of each timing channel signal. 
 
 
Zeroing the Machine (setting the resolver offset):  To set 
machine zero, perform the following: 
 
1) Connect an RS-232 SYSdev cable from the COM port on the 

computer to the “PROG” port on the M4500.   
 
2) From the “Window” menu, select “Machine Timing”. 
 
3) From the “View” menu, select “Online Data”.  The set-up 

program will attempt to communicate with the processor and 
place the system into an “Online” mode of operation. 

 
4) Observe the “Position” field at the bottom of the window.  Verify 

that as the machine is rotated forward, that the position increases 
linearly from 0 through 359 degrees.  If not, swap the S1 and S3 
leads at the resolver connector on the M4500.  Then, verify that 
the position does indeed increase with forward movement. 

 
5) Position the machine at machine zero (inch the bodymaker to back 

dead center BDC). 
 
6) Auto zero the resolver by entering “0” in the “Resolver Offset” 

field and clicking the “Set Offset” command button.  A message 
box will appear, prompting the user to confirm their choice.  
Select “Yes” to set the resolver offset. 

 
7) The M4500 will calculate the actual offset value required to make 

this the “0” position.  The new offset value will be displayed in 
the “Offset” field and the position will then read zero. 
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Adjusting the Timing Channel Setpoints:  To set any of the 
timing signal setpoints, perform the following: 
 
Note:  Any changes made to the timing channel setpoints will be 
saved as part of the setup data file. 
 
1) Connect an RS-232 SYSdev cable from the COM port on the 

computer to the “PROG” port on the M4510.   
 
2) From the “Window” menu, select “Machine Timing”. 
 
3) From the “View” menu, select “Online Data”.  The set-up 

program will attempt to communicate with the processor and 
place the system into an “Online” mode of operation. 

 
4) Set all channels per section 6 – General Timing Signal Locations.  

Setpoints for a particular channel are either entered in the field or 
adjusted by using the increment/decrement controls. 

 
 Note: Only one set-point is used per channel.  
 
5) If a channel needs to be “Recalled” or “Cleared”, enter the desired 

channel number into the “PLS Channel” field.  Click the “Recall 
Channel” command button to recall the setpoints.  Click the 
“Clear Channel” command button the completely clear all 
setpoints for the selected channel. 

  
 Note:  If a channel has been cleared or the “On” and “Off” 

setpoints have the same setting, the set-point will be displayed as 
“*****”. 
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Resetting the PLS Configuration:  As an aid to the user the 
current PLS configuration is displayed in the “PLS Configuration” tab 
of this window.  The PLS configuration should only be reset if a new 
module has been installed.  To reset the PLS configuration, click the 
“Reset PLS Config” command button.  This function only resets the 
PLS configuration to the default settings. 
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________________________________________________________ 
4.5.4 THE SHIFT DATA WINDOW 
 
The “Shift Data” window is used to view the shift data collected by 
the M4500.  This window is selected from the “Window” menu. 
 

 
 
Current Shift Data:  This data is the totals so far into the shift.  
This data is transferred to the "Last shift" at the end of either an 8 or 
12 hour shift or alternatively could be done at label changes such that 
the data collected would be for label runs rather than complete shifts.  
This data can be reset by the user from this section. 
 
Note:  The “Transfer Data” command button is only active while 
“Online”.   
 
1) Total Good Cans: This is the total number of good cans 

produced so far into the current shift.  This is essentially a can 
counter. 

 
2) Total Short Can Faults: This is the total number of short can 

faults that have occurred so far into the current shift. 
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Last Shift Data:  The "Last Shift" data is for the previous 8 or 12 
hour shift, however the shift collection is set-up.  This allows data 
collection and diagnostics to take place automatically over a two shift 
period. 
 
 
________________________________________________________ 
4.5.5 THE I/O STATES WINDOW 
 
The “I/O States” window is provided to display states of the inputs 
and outputs.  The control boards, the states of the timing channels, as 
well as states of the M4500 are shown.  This includes the interrupt 
inputs (IN0 and IN1), the analog I/O and the resolver.  These values 
are displayed as read by the M4500 processor. 
 

 
 
 
 
 


